{"_id":"590a04f8ed80861900cbc7b5","parentDoc":null,"__v":0,"category":{"_id":"590a04f3ed80861900cbc74c","__v":0,"version":"590a04f2ed80861900cbc737","project":"55b2d5baa74a380d00e290c4","sync":{"url":"","isSync":false},"reference":false,"createdAt":"2016-01-05T19:32:59.974Z","from_sync":false,"order":22,"slug":"troubleshooting","title":"Troubleshooting"},"user":"55b2d5626862a10d00887af9","version":{"_id":"590a04f2ed80861900cbc737","project":"55b2d5baa74a380d00e290c4","__v":4,"createdAt":"2017-05-03T16:27:30.085Z","releaseDate":"2017-05-03T16:27:30.085Z","categories":["590a04f3ed80861900cbc738","590a04f3ed80861900cbc739","590a04f3ed80861900cbc73a","590a04f3ed80861900cbc73b","590a04f3ed80861900cbc73c","590a04f3ed80861900cbc73d","590a04f3ed80861900cbc73e","590a04f3ed80861900cbc73f","590a04f3ed80861900cbc740","590a04f3ed80861900cbc741","590a04f3ed80861900cbc742","590a04f3ed80861900cbc743","590a04f3ed80861900cbc744","590a04f3ed80861900cbc745","590a04f3ed80861900cbc746","590a04f3ed80861900cbc747","590a04f3ed80861900cbc748","590a04f3ed80861900cbc749","590a04f3ed80861900cbc74a","590a04f3ed80861900cbc74b","590a04f3ed80861900cbc74c","590a04f3ed80861900cbc74d","59124949de13f61900336a7a","5914b04e7c2c552d008b7104","5914b47242c6a22300b9dc20"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":true,"codename":"","version_clean":"7.0.0","version":"7"},"project":"55b2d5baa74a380d00e290c4","updates":[],"next":{"pages":[],"description":""},"createdAt":"2016-11-18T00:22:24.833Z","link_external":false,"link_url":"","githubsync":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":12,"body":"On Nov 11, 2016, introduced a breaking change that affects customers using 0.x versions of CocoaPods.\n\nYou can read the the details of this change on their blog here: http://blog.cocoapods.org/Sharding/\n\nIf you are using an older version of CocoaPods, you might start seeing failures in buddybuild. You will very likely see the same errors if you run 'pod install' locally.\n\nThere are a few options you can try:\n- Upgrade to CocoaPods 1.x\n- Check your Pods folder into your git repo","excerpt":"","slug":"spec-repo-not-compatible-with-older-cocoapods-versions","type":"basic","title":"Spec repo not compatible with older CocoaPods versions"}

Spec repo not compatible with older CocoaPods versions


On Nov 11, 2016, introduced a breaking change that affects customers using 0.x versions of CocoaPods. You can read the the details of this change on their blog here: http://blog.cocoapods.org/Sharding/ If you are using an older version of CocoaPods, you might start seeing failures in buddybuild. You will very likely see the same errors if you run 'pod install' locally. There are a few options you can try: - Upgrade to CocoaPods 1.x - Check your Pods folder into your git repo